Archivo de la etiqueta: development

Android Studio won’t start on Windows 8 [Fix]

After installing the android studio on my laptop running windows 8 it wasn’t able to start. The root cause: the java path wasn’t declared in global environment variables so let’s do this quick:

1 – Right click on your computer icon and select properties:
mycomputer_icon

2 – Click on Advanced system settings:
advanced_system_settings

3 – Select the “Advanced” tab and then click on the “Environment variables..” button:system_properties

4 – If the variable called “JAVA_HOME” doesn’t exist then click on the button “New…” and add a new variable called “JAVA_HOME” as showed in the picture:

new_variable

5 – Fill it with path of your java JDK or JRE installation:

jdk_path

system_variable_props

6 – Next click OK button to save the changes

7 – Now edit the “path” variable and check if it contain the route for the JDK or JRE “bin” folder:

edit_path

The value of the path variable may be a little longer, so read it carefully, if it doesn’t exist then add first a semicolon ( ; ) and then insert the path like this:

path_value

jdk_bin_path

8 – Finally click on “OK” to save it, and then OK in all previously opened windows.

9 – You should be able to start your Android Studio now:

android_studio

Maybe you encounter another cause, but this was mine and I just posted how to solve it, so that’s all,and happy coding!!!

 

Request for the permission of type ‘System.Security.Permissions.FileIOPermission, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089′ failed.’

Hace unos días, estaba confrontando una excepción intermitente en un hosting compartido (godaddy.com), el problema vino luego que moví toda una aplicación a un sub-directorio. Buscando en google dí con la solución (de hecho archivada en MSDN). En dicho post recomiendan cambiar el trust-level para resolver el inconveniente, desde luego esta acción debe ser solo efectuada si tienes dominio y conoces la procedencia de manera segura de las librerías a las cuales has hecho referencia.

El cambio en cuestión es agregar la siguiente linea (si ya existe solo hay que modificarla) en el archivo web.config de su aplicación para que quede así:
<trust level="Full" originUrl=""/>

Esta etiqueta debe ir dentro de la etiqueta raíz <system.web></system.web>

Suerte con eso!